0 0 Share PDF

Which package versions are required by Docker?

Article ID: KB000680

To find which package versions are required by Docker, using the following command:

$ yum deplist docker-ee
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
...
package: docker-ee.x86_64 2:17.06.2.ee.8-3.el7.rhel
  dependency: /bin/sh
   provider: bash.x86_64 4.2.46-29.el7_4
  dependency: /usr/bin/env
   provider: coreutils.x86_64 8.22-18.el7
  dependency: container-selinux >= 2.9
   provider: container-selinux.noarch 2:2.42-1.gitad8f0f7.el7
  dependency: device-mapper-libs >= 1.02.90-1
   provider: device-mapper-libs.x86_64 7:1.02.140-8.el7
   provider: device-mapper-libs.i686 7:1.02.140-8.el7
  dependency: iptables
   provider: iptables-services.x86_64 1.4.21-18.3.el7_4
   provider: iptables.x86_64 1.4.21-18.3.el7_4
   provider: iptables.i686 1.4.21-18.3.el7_4
  dependency: libc.so.6(GLIBC_2.17)(64bit)
   provider: glibc.x86_64 2.17-196.el7_4.2
  dependency: libcgroup
   provider: libcgroup.x86_64 0.41-13.el7
   provider: libcgroup.i686 0.41-13.el7
  dependency: libdevmapper.so.1.02()(64bit)
   provider: device-mapper-libs.x86_64 7:1.02.140-8.el7
  dependency: libdevmapper.so.1.02(Base)(64bit)
   provider: device-mapper-libs.x86_64 7:1.02.140-8.el7
  dependency: libdevmapper.so.1.02(DM_1_02_97)(64bit)
   provider: device-mapper-libs.x86_64 7:1.02.140-8.el7
  dependency: libdl.so.2()(64bit)
   provider: glibc.x86_64 2.17-196.el7_4.2
  dependency: libdl.so.2(GLIBC_2.2.5)(64bit)
   provider: glibc.x86_64 2.17-196.el7_4.2
  dependency: libltdl.so.7()(64bit)
   provider: libtool-ltdl.x86_64 2.4.2-22.el7_3
  dependency: libpthread.so.0()(64bit)
   provider: glibc.x86_64 2.17-196.el7_4.2
  dependency: libpthread.so.0(GLIBC_2.2.5)(64bit)
   provider: glibc.x86_64 2.17-196.el7_4.2
  dependency: libpthread.so.0(GLIBC_2.3.2)(64bit)
   provider: glibc.x86_64 2.17-196.el7_4.2
  dependency: libseccomp.so.2()(64bit)
   provider: libseccomp.x86_64 2.3.1-3.el7
  dependency: libsystemd.so.0()(64bit)
   provider: systemd-libs.x86_64 219-42.el7_4.10
  dependency: libsystemd.so.0(LIBSYSTEMD_209)(64bit)
   provider: systemd-libs.x86_64 219-42.el7_4.10
  dependency: rtld(GNU_HASH)
   provider: glibc.x86_64 2.17-196.el7_4.2
   provider: glibc.i686 2.17-196.el7_4.2
  dependency: systemd-units
   provider: systemd.x86_64 219-42.el7_4.10
  dependency: tar
   provider: tar.x86_64 2:1.26-32.el7
  dependency: xz
   provider: xz.x86_64 5.2.2-1.el7

To find a specific package version required, use the same command along with grep to find information about the specific package:

$ yum deplist docker-ee | grep container-selinux
Failed to set locale, defaulting to C
  dependency: container-selinux >= 2.9
   provider: container-selinux.noarch 2:2.42-1.gitad8f0f7.el7